const regex = new RegExp('\\b(?:[01][0-9]|2[0-3])[0-5][0-9]\\b', 'gm')
const str = `2359
0000
1330
2400
2360
2500
1322
0001
2500
2400
2359
0123
4321
2059`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}