import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[01][0-9]|2[0-3])[0-5][0-9]\\b";
final String string = "2359\n"
+ "0000\n"
+ "1330\n\n"
+ "2400\n"
+ "2360\n"
+ "2500\n\n"
+ "1322\n"
+ "0001\n"
+ "2500\n"
+ "2400\n"
+ "2359\n"
+ "0123\n"
+ "4321\n"
+ "2059";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}