$re = '/\b(?:[01][0-9]|2[0-3])[0-5][0-9]\b/m';
$str = '2359
0000
1330
2400
2360
2500
1322
0001
2500
2400
2359
0123
4321
2059';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);