using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[01][0-9]|2[0-3])[0-5][0-9]\b";
string input = @"2359
0000
1330
2400
2360
2500
1322
0001
2500
2400
2359
0123
4321
2059";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}