#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{0,20}(.*)).*?\K\S+V\b(?=.*?\1)"
Local $sString = "SEBSTI FMDE OPORV AWEN STEM students into STEM" & @CRLF & _
"SEBSTI FMDE OPOR AWEN STEM students into STEMV" & @CRLF & _
"SEBSTI FMDE OPORV AWEN STEM students into STEMV" & @CRLF & _
"" & @CRLF & _
"ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event " & @CRLF & _
"" & @CRLF & _
"ARKFE SSETE BLME CARFR Academy IV Networking Event" & @CRLF & _
"ARKFE SSETE BLMEV CARFR Academy IV Networking Event"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")