re = /^(?=.{0,20}(.*)).*?\K\S+V\b(?=.*?\1)/m
str = 'SEBSTI FMDE OPORV AWEN STEM students into STEM
SEBSTI FMDE OPOR AWEN STEM students into STEMV
SEBSTI FMDE OPORV AWEN STEM students into STEMV
ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event
ARKFE SSETE BLME CARFR Academy IV Networking Event
ARKFE SSETE BLMEV CARFR Academy IV Networking Event'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end