using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{0,20}(.*)).*?\K\S+V\b(?=.*?\1)";
string input = @"SEBSTI FMDE OPORV AWEN STEM students into STEM
SEBSTI FMDE OPOR AWEN STEM students into STEMV
SEBSTI FMDE OPORV AWEN STEM students into STEMV
ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event
ARKFE SSETE BLME CARFR Academy IV Networking Event
ARKFE SSETE BLMEV CARFR Academy IV Networking Event";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}