import Foundation
let pattern = #"^(?=.{0,20}(.*)).*?\K\S+V\b(?=.*?\1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SEBSTI FMDE OPORV AWEN STEM students into STEM
SEBSTI FMDE OPOR AWEN STEM students into STEMV
SEBSTI FMDE OPORV AWEN STEM students into STEMV
ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event
ARKFE SSETE BLME CARFR Academy IV Networking Event
ARKFE SSETE BLMEV CARFR Academy IV Networking Event
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)