import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{0,20}(.*)).*?\\K\\S+V\\b(?=.*?\\1)";
final String string = "SEBSTI FMDE OPORV AWEN STEM students into STEM\n"
+ "SEBSTI FMDE OPOR AWEN STEM students into STEMV\n"
+ "SEBSTI FMDE OPORV AWEN STEM students into STEMV\n\n"
+ "ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event \n\n"
+ "ARKFE SSETE BLME CARFR Academy IV Networking Event\n"
+ "ARKFE SSETE BLMEV CARFR Academy IV Networking Event";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}