# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.{0,20}(.*)).*?\K\S+V\b(?=.*?\1)"
test_str = ("SEBSTI FMDE OPORV AWEN STEM students into STEM\n"
"SEBSTI FMDE OPOR AWEN STEM students into STEMV\n"
"SEBSTI FMDE OPORV AWEN STEM students into STEMV\n\n"
"ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event \n\n"
"ARKFE SSETE BLME CARFR Academy IV Networking Event\n"
"ARKFE SSETE BLMEV CARFR Academy IV Networking Event")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.