use strict;
my $str = 'SEBSTI FMDE OPORV AWEN STEM students into STEM
SEBSTI FMDE OPOR AWEN STEM students into STEMV
SEBSTI FMDE OPORV AWEN STEM students into STEMV
ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event
ARKFE SSETE BLME CARFR Academy IV Networking Event
ARKFE SSETE BLMEV CARFR Academy IV Networking Event';
my $regex = qr/^(?=.{0,20}(.*)).*?\K\S+V\b(?=.*?\1)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}