const regex = /^(?=.{0,20}(.*)).*?\K\S+V\b(?=.*?\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{0,20}(.*)).*?\\K\\S+V\\b(?=.*?\\1)', 'gm')
const str = `SEBSTI FMDE OPORV AWEN STEM students into STEM
SEBSTI FMDE OPOR AWEN STEM students into STEMV
SEBSTI FMDE OPORV AWEN STEM students into STEMV
ARKFE SSETE BLMI EDSF BRNT CARFR (name removed) Academy Networking Event
ARKFE SSETE BLME CARFR Academy IV Networking Event
ARKFE SSETE BLMEV CARFR Academy IV Networking Event`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}