import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)<p><a .+href=\".+\">.+<\\/a><\\/p>\\s(.*)$";
final String string = "<h3>СВЕРХПЛОТНОЕ ЗАЩИТНОЕ ПОКРЫТИЕ</h3>\n"
+ "<p>Тут текст описание и бла-бла-бла</p>\n"
+ "<p>Состав бла-бла-бла</p>\n"
+ "<p><a class=\"download pdf\" href=\"assets/files/techdoc1.pdf\" target=\"_blank\"><span>Тех. описание Товара</span></a></p>\n"
+ "<h3>Область применения</h3>\n"
+ "<p>Область применения и бла-бла-бла</p>";
final String subst = "$1<!------- Вырезанная ссылка --------->\\n$2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}