$re = '/(.*)<p><a .+href=".+">.+<\/a><\/p>\s(.*)$/si';
$str = '<h3>СВЕРХПЛОТНОЕ ЗАЩИТНОЕ ПОКРЫТИЕ</h3>
<p>Тут текст описание и бла-бла-бла</p>
<p>Состав бла-бла-бла</p>
<p><a class="download pdf" href="assets/files/techdoc1.pdf" target="_blank"><span>Тех. описание Товара</span></a></p>
<h3>Область применения</h3>
<p>Область применения и бла-бла-бла</p>';
$subst = "$1<!------- Вырезанная ссылка --------->\n$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;