const regex = /(.*)<p><a .+href=".+">.+<\/a><\/p>\s(.*)$/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)<p><a .+href=".+">.+<\\\/a><\\\/p>\\s(.*)$', 'si')
const str = `<h3>СВЕРХПЛОТНОЕ ЗАЩИТНОЕ ПОКРЫТИЕ</h3>
<p>Тут текст описание и бла-бла-бла</p>
<p>Состав бла-бла-бла</p>
<p><a class="download pdf" href="assets/files/techdoc1.pdf" target="_blank"><span>Тех. описание Товара</span></a></p>
<h3>Область применения</h3>
<p>Область применения и бла-бла-бла</p>`;
const subst = `$1<!------- Вырезанная ссылка --------->\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);