import re
regex = re.compile(r"(.*)<p><a .+href=\".+\">.+<\/a><\/p>\s(.*)$", flags=re.DOTALL | re.IGNORECASE)
test_str = ("<h3>СВЕРХПЛОТНОЕ ЗАЩИТНОЕ ПОКРЫТИЕ</h3>\n"
"<p>Тут текст описание и бла-бла-бла</p>\n"
"<p>Состав бла-бла-бла</p>\n"
"<p><a class=\"download pdf\" href=\"assets/files/techdoc1.pdf\" target=\"_blank\"><span>Тех. описание Товара</span></a></p>\n"
"<h3>Область применения</h3>\n"
"<p>Область применения и бла-бла-бла</p>")
subst = "$1<!------- Вырезанная ссылка --------->\\n$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)