use strict;
my $str = '<h3>СВЕРХПЛОТНОЕ ЗАЩИТНОЕ ПОКРЫТИЕ</h3>
<p>Тут текст описание и бла-бла-бла</p>
<p>Состав бла-бла-бла</p>
<p><a class="download pdf" href="assets/files/techdoc1.pdf" target="_blank"><span>Тех. описание Товара</span></a></p>
<h3>Область применения</h3>
<p>Область применения и бла-бла-бла</p>';
my $regex = qr/(.*)<p><a .+href=".+">.+<\/a><\/p>\s(.*)$/sip;
my $subst = '$1<!------- Вырезанная ссылка --------->\\n$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";