#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^urn:abc:de:xyz:\d{6,12}\.\d{1,7}(?:\.[\w-]{1,20})+$"
Local $sString = "urn:abc:de:xyz:234567.1890123.abd12" & @CRLF & _
"urn:abc:de:xyz:234567.1890123" & @CRLF & _
"urn:abc:de:xyz:234567.1890ANC" & @CRLF & _
"urn:abc:de:xyz:234567.1890123" & @CRLF & _
"urn:abc:de:xyz:234567.1890ACB.123" & @CRLF & _
"" & @CRLF & _
"urn:abc:de:xyz:234567.1890123.ABC123.-_12" & @CRLF & _
"urn:abc:de:xyz:234567.1890ABC.ABC123.-_12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")