import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^urn:abc:de:xyz:\\d{6,12}\\.\\d{1,7}(?:\\.[\\w-]{1,20})+$";
final String string = "urn:abc:de:xyz:234567.1890123.abd12\n"
+ "urn:abc:de:xyz:234567.1890123\n"
+ "urn:abc:de:xyz:234567.1890ANC\n"
+ "urn:abc:de:xyz:234567.1890123\n"
+ "urn:abc:de:xyz:234567.1890ACB.123\n\n"
+ "urn:abc:de:xyz:234567.1890123.ABC123.-_12\n"
+ "urn:abc:de:xyz:234567.1890ABC.ABC123.-_12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}