using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^urn:abc:de:xyz:\d{6,12}\.\d{1,7}(?:\.[\w-]{1,20})+$";
string input = @"urn:abc:de:xyz:234567.1890123.abd12
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ANC
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ACB.123
urn:abc:de:xyz:234567.1890123.ABC123.-_12
urn:abc:de:xyz:234567.1890ABC.ABC123.-_12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}