import re
regex = re.compile(r"^urn:abc:de:xyz:\d{6,12}\.\d{1,7}(?:\.[\w-]{1,20})+$", flags=re.MULTILINE)
test_str = ("urn:abc:de:xyz:234567.1890123.abd12\n"
"urn:abc:de:xyz:234567.1890123\n"
"urn:abc:de:xyz:234567.1890ANC\n"
"urn:abc:de:xyz:234567.1890123\n"
"urn:abc:de:xyz:234567.1890ACB.123\n\n"
"urn:abc:de:xyz:234567.1890123.ABC123.-_12\n"
"urn:abc:de:xyz:234567.1890ABC.ABC123.-_12")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")