import Foundation
let pattern = #"^urn:abc:de:xyz:\d{6,12}\.\d{1,7}(?:\.[\w-]{1,20})+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
urn:abc:de:xyz:234567.1890123.abd12
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ANC
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ACB.123
urn:abc:de:xyz:234567.1890123.ABC123.-_12
urn:abc:de:xyz:234567.1890ABC.ABC123.-_12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)