package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^urn:abc:de:xyz:\d{6,12}\.\d{1,7}(?:\.[\w-]{1,20})+$`)
var str = `urn:abc:de:xyz:234567.1890123.abd12
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ANC
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ACB.123
urn:abc:de:xyz:234567.1890123.ABC123.-_12
urn:abc:de:xyz:234567.1890ABC.ABC123.-_12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}