const regex = /^urn:abc:de:xyz:\d{6,12}\.\d{1,7}(?:\.[\w-]{1,20})+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^urn:abc:de:xyz:\\d{6,12}\\.\\d{1,7}(?:\\.[\\w-]{1,20})+$', 'gm')
const str = `urn:abc:de:xyz:234567.1890123.abd12
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ANC
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ACB.123
urn:abc:de:xyz:234567.1890123.ABC123.-_12
urn:abc:de:xyz:234567.1890ABC.ABC123.-_12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}