#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\\usepackage{(?:tikz|pgfplots)}|\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\(?:usetikzlibrary|usepgfplotslibrary){[\w\.,]+}|\\definecolor{\w+}{\w+}{[^}]+}|\\colorlet{\w+}{{[^}]+}})"
Local $sString = "\documentclass{article}" & @CRLF & _
"\usepackage{tikz}" & @CRLF & _
"\usetikzlibrary{decorations.markings}" & @CRLF & _
"" & @CRLF & _
"\tikzset{" & @CRLF & _
" ->-/.style={" & @CRLF & _
" postaction=decorate," & @CRLF & _
" decoration={markings,mark=at position #1 with \arrow{>}}" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"\begin{document}" & @CRLF & _
"\begin{center}" & @CRLF & _
" \begin{tikzpicture}" & @CRLF & _
" \draw[->-=0.5] (0,0) -- (3,-2);" & @CRLF & _
" \end{tikzpicture}" & @CRLF & _
"\end{center}" & @CRLF & _
"\end{document}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")