use strict;
my $str = '\\documentclass{article}
\\usepackage{tikz}
\\usetikzlibrary{decorations.markings}
\\tikzset{
->-/.style={
postaction=decorate,
decoration={markings,mark=at position #1 with \\arrow{>}}
}
}
\\begin{document}
\\begin{center}
\\begin{tikzpicture}
\\draw[->-=0.5] (0,0) -- (3,-2);
\\end{tikzpicture}
\\end{center}
\\end{document}';
my $regex = qr/(\\usepackage{(?:tikz|pgfplots)}|\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\(?:usetikzlibrary|usepgfplotslibrary){[\w\.,]+}|\\definecolor{\w+}{\w+}{[^}]+}|\\colorlet{\w+}{{[^}]+}})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}