re = /(\\usepackage{(?:tikz|pgfplots)}|\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\(?:usetikzlibrary|usepgfplotslibrary){[\w\.,]+}|\\definecolor{\w+}{\w+}{[^}]+}|\\colorlet{\w+}{{[^}]+}})/m
str = '\\documentclass{article}
\\usepackage{tikz}
\\usetikzlibrary{decorations.markings}
\\tikzset{
->-/.style={
postaction=decorate,
decoration={markings,mark=at position #1 with \\arrow{>}}
}
}
\\begin{document}
\\begin{center}
\\begin{tikzpicture}
\\draw[->-=0.5] (0,0) -- (3,-2);
\\end{tikzpicture}
\\end{center}
\\end{document}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end