import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\usepackage\\{(?:tikz|pgfplots)\\}|\\\\(?:tikzset|pgfplotsset)\\{(?:[^\\{\\}]+|\\{(?:[^\\{\\}]+|\\{(?:[^\\{\\}]+|\\{[^\\{\\}]+\\})+\\})+\\})+\\}|\\\\(?:usetikzlibrary|usepgfplotslibrary)\\{[\\w\\.,]+\\}|\\\\definecolor\\{\\w+\\}\\{\\w+\\}\\{[^\\}]+\\}|\\\\colorlet\\{\\w+\\}\\{\\{[^\\}]+\\}\\})";
final String string = "\\documentclass{article}\n"
+ "\\usepackage{tikz}\n"
+ "\\usetikzlibrary{decorations.markings}\n\n"
+ "\\tikzset{\n"
+ " ->-/.style={\n"
+ " postaction=decorate,\n"
+ " decoration={markings,mark=at position #1 with \\arrow{>}}\n"
+ " }\n"
+ "}\n\n"
+ "\\begin{document}\n"
+ "\\begin{center}\n"
+ " \\begin{tikzpicture}\n"
+ " \\draw[->-=0.5] (0,0) -- (3,-2);\n"
+ " \\end{tikzpicture}\n"
+ "\\end{center}\n"
+ "\\end{document}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}