using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\usepackage{(?:tikz|pgfplots)}|\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\(?:usetikzlibrary|usepgfplotslibrary){[\w\.,]+}|\\definecolor{\w+}{\w+}{[^}]+}|\\colorlet{\w+}{{[^}]+}})";
string input = @"\documentclass{article}
\usepackage{tikz}
\usetikzlibrary{decorations.markings}
\tikzset{
->-/.style={
postaction=decorate,
decoration={markings,mark=at position #1 with \arrow{>}}
}
}
\begin{document}
\begin{center}
\begin{tikzpicture}
\draw[->-=0.5] (0,0) -- (3,-2);
\end{tikzpicture}
\end{center}
\end{document}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}