package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\\usepackage{(?:tikz|pgfplots)}|\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\(?:usetikzlibrary|usepgfplotslibrary){[\w\.,]+}|\\definecolor{\w+}{\w+}{[^}]+}|\\colorlet{\w+}{{[^}]+}})`)
var str = `\documentclass{article}
\usepackage{tikz}
\usetikzlibrary{decorations.markings}
\tikzset{
->-/.style={
postaction=decorate,
decoration={markings,mark=at position #1 with \arrow{>}}
}
}
\begin{document}
\begin{center}
\begin{tikzpicture}
\draw[->-=0.5] (0,0) -- (3,-2);
\end{tikzpicture}
\end{center}
\end{document}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}