# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\nitem\b)//;t' <<< "Item
Notitem
Not an item
item
item
item
item
item
"