re = /(\nitem\b)/
str = 'Item
Notitem
Not an item
item
item
item
item
item
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result