use strict;
my $str = 'Item
Notitem
Not an item
item
item
item
item
item
';
my $regex = qr/(\nitem\b)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";