const regex = new RegExp('(\\nitem\\b)', '')
const str = `Item
Notitem
Not an item
item
item
item
item
item
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);