const regex = /\/s\d+x\d+\//;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/s\\d+x\\d+\\\/', '')
const str = `cd.com/vp/3070d0210e464e/5AEFB3ED/t51.2885/s150x150/24845474_1790806444289980_66798452736_n.jpg
`;
const subst = `/s720x720/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);