re = /\/s\d+x\d+\//
str = 'cd.com/vp/3070d0210e464e/5AEFB3ED/t51.2885/s150x150/24845474_1790806444289980_66798452736_n.jpg
'
subst = '/s720x720/'
result = str.sub(re, subst)
# Print the result of the substitution
puts result