#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^\d{3}|^\d{7})(?=\d)"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"1231" & @CRLF & _
"1231234" & @CRLF & _
"12312341" & @CRLF & _
"123123412345"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)