use strict;
my $str = '1
12
123
1231
1231234
12312341
123123412345';
my $regex = qr/(?<=^\d{3}|^\d{7})(?=\d)/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";