import re
regex = re.compile(r"(?<=^\d{3}|^\d{7})(?=\d)", flags=re.MULTILINE)
test_str = ("1\n"
"12\n"
"123\n"
"1231\n"
"1231234\n"
"12312341\n"
"123123412345")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)