re = /(?<=^\d{3}|^\d{7})(?=\d)/m
str = '1
12
123
1231
1231234
12312341
123123412345'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result