using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^\d{3}|^\d{7})(?=\d)";
string substitution = @"-";
string input = @"1
12
123
1231
1231234
12312341
123123412345";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}