const regex = /(?<=^\d{3}|^\d{7})(?=\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^\\d{3}|^\\d{7})(?=\\d)', 'gm')
const str = `1
12
123
1231
1231234
12312341
123123412345`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);