import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^\\d{3}|^\\d{7})(?=\\d)";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "1231\n"
+ "1231234\n"
+ "12312341\n"
+ "123123412345";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}