using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([^\.]{2,3}(?![^\.])\+?).*|.*\.(.*))([0-9]{2})$";
string substitution = @"$1$2$3";
string input = @"BCPP.Boc+20
BCP+.Boc+20
Boc.Boc+20
BCP.Boc+20
BC.Boc+20
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}