import Foundation
let pattern = #"(?:([^\.]{2,3}(?![^\.])\+?).*|.*\.(.*))([0-9]{2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BCPP.Boc+20
BCP+.Boc+20
Boc.Boc+20
BCP.Boc+20
BC.Boc+20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)