const regex = new RegExp('(?:([^\\.]{2,3}(?![^\\.])\\+?).*|.*\\.(.*))([0-9]{2})$', 'gm')
const str = `BCPP.Boc+20
BCP+.Boc+20
Boc.Boc+20
BCP.Boc+20
BC.Boc+20
`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);