use strict;
my $str = 'BCPP.Boc+20
BCP+.Boc+20
Boc.Boc+20
BCP.Boc+20
BC.Boc+20
';
my $regex = qr/(?:([^\.]{2,3}(?![^\.])\+?).*|.*\.(.*))([0-9]{2})$/mp;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";