import re
regex = re.compile(r"(?:([^\.]{2,3}(?![^\.])\+?).*|.*\.(.*))([0-9]{2})$", flags=re.MULTILINE)
test_str = ("BCPP.Boc+20\n"
"BCP+.Boc+20\n"
"Boc.Boc+20\n"
"BCP.Boc+20\n"
"BC.Boc+20\n")
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)