# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<pre>((?:[^\n]+?))<\/pre>/<p>$1<\/p>\n/g;t' <<< "<pre>one</pre><p><b>two</b></p>\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>"