using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<pre>((?:[^\n]+?))</pre>";
string substitution = @"<p>$1</p>\n";
string input = @"<pre>one</pre><p><b>two</b></p>\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}